Erreur soudaine 404 non trouvée sur tous les fichiers de mon application Java GAE sans aucune modification des fichiers ou des configurations

Je cours une application GAE payante écrite en Java et son identifiant est le partage de clip, donc l'URL est http://clip-share.appspot.com/ .

Je l'ai couru pendant plus de 10 mois, et depuis 2 jours, il commence à ne pas fonctionner avec 404 erreur introuvable sur toutes les URL statiques et dynamiques.

Lorsque je me connecte à l'URL de mon application, cela envoie simplement le message qu'il n'existe aucun fichier index.html qui existe réellement.

Error: Not Found
The requested URL /index.html was not found on this server.

J'ai essayé de redéployer cette application pour quelques fois, mais cela fonctionne sans problème juste quelques minutes juste après le déploiement, mais cela ne fonctionne pas après cela.

Et aussi cherché le problème 404 pas trouvé, j'ai trouvé ce fil mais il n'y a pas d'informations spécifiques sur la cause et un moyen de le résoudre.

https://groups.google.com/d/topic/google -appengine/8liP4T-wbSo/discussion

Alors que se passe-t-il? et comment puis-je le gérer?

EDIT:

J'ai trouvé une solution de contournement pour ce problème, c'est faire une autre version, disons la version 2, et le définir par défaut. Mais vous pouvez toujours voir le problème dans cette URL pour la version 1, il suffit de mettre 1. juste avant l'URL. (Je veux vous montrer l'URL complète de la version 1, mais je suis plutôt nouveau sur stackoverflow.com, et je ne suis pas autorisé à poster plus de 2 URL dans une question.)

Donc, le même code et la configuration dans deux versions différentes, mais seulement la version 2, la plus récente fonctionne.

0
Ce n'est pas une application si célèbre et est encore loin des limites :)
ajouté l'auteur ckang, source
avez-vous dépassé les limites de l'utilisation des données et de l'espace disque
ajouté l'auteur pshirishreddy, source

2 Réponses

Il s'avère qu'il y avait un problème de configuration dans le plugin Google App Engine d'Eclipse. J'ai plusieurs projets GAE dans un espace de travail Eclipse et un autre projet GAE déployé accidentellement sur le partage de clips. Donc, il semble qu'il y avait 404 problèmes non trouvés, soudainement. Quoi qu'il en soit, merci les gars.

0
ajouté

dans web.xml devrait être la balise de fichier de bienvenue. Peut-être avez-vous /index.html. Trouvez dans web.xml "/index.html" et remplacez-le par "index.html".

Le fichier index.html doit être dans le dossier war: /war/index.html

0
ajouté
Comme je l'ai écrit ci-dessus, il fonctionne pendant quelques minutes juste après le déploiement, et commence à échouer avec 404. Tout à fait étrange, n'est-ce pas?
ajouté l'auteur ckang, source