Geoip2 demande la clé secrète gpg

J'essaie d'utiliser geoip2 localement. Je n'ai aucun gpg installé. Je reçois "gpg: pas de clé secrète par défaut: clé secrète inutilisable". Devrais-je installer gpg en premier? Quoi d'autre peut-être manquer?

0
Avez-vous SSL installé sur votre machine? Je crois que l'API a exigé que la bibliothèque cryptographique soit installée en premier.
ajouté l'auteur Michael C., source
L'API est geoip2-0.7.0.jar, maxminddb-0.2.0.jar Pas sûr si elle a besoin de SSL car elle demande explicitement GPG (pas pour PGP 8-). Je pense avoir du ssl sur ma machine (Win 7) car il est capable de lire https. Va essayer d'installer GPG ...
ajouté l'auteur Dima, source
GeoIP2 est juste une base de données. Essayez-vous d'installer l'une des API? Si oui, lequel?
ajouté l'auteur Greg Oschwald, source
(TgLINUX) GNU/LINUX fr-Tchat TeleGram
(TgLINUX) GNU/LINUX fr-Tchat TeleGram
565 des participants

Groupe d'échange et d'entraide sur les OS GNU/Linux exclusivement, ouvert au public débutants,passionnés & habitués. $sudo ./bienvenue.sh REGLES(CGU): http://telegra.ph/TgLinux-09-03 FBK,TWEET: @TgLinux CHAINE:@UbuntuFacile @FrLibreOffice