Les onglets principaux de Drupal 8 Admin complètement disparus

Je construis un site dans Drupal 8, et j'ai poussé mon code de local vers notre boîte de développement, et sur la boîte de développement, les onglets principaux admin ont complètement disparu. Partout. Ce qui suit est une capture d'écran du problème.

http://i.stack.imgur.com/NB6Sp.png

Le code est contrôlé par la version (git), et les bases de données sont identiques. Il n'y a pas de modifications de configuration en attente à synchroniser. Je me tire les cheveux en essayant de comprendre quel est le problème. Y a-t-il des réglages quelque part qui me manquent? J'ai essayé de me déconnecter, d'effacer le cache, un navigateur différent. Rien. Je voulais obtenir une seconde option avant de soumettre un rapport sur drupal.org.

0

3 Réponses

La reconstruction du cache sur le serveur de développement a résolu le problème.

0
ajouté

@see Where are the primary and secondary tab blocks?

Vous avez probablement installé le profil minimal . Et bien que ces blocs font partie du thème Seven, ils ne sont installés que dans le profil standard. Cela ressemble à un bug. Comme ils devraient plutôt être installés lors de l'installation du thème au lieu de lors de l'installation du profil.

Essayez ceci:

     

Utilisez la console Drush ou Drupal ou la configuration intégrée   Synchronisation pour exporter votre configuration actuelle. Puis copiez le   fichiers de configuration ...

     

core/profiles/standard/config/install/bloc.block.seven_local_actions.yml   core/profiles/standard/config/install/block.block.seven_page_title.yml   core/profiles/standard/config/install/block.block.seven_primary_local_tasks.yml   core/profiles/standard/config/install/block.block.seven_secondary_local_tasks.yml

     

... dans votre dossier de configuration - qui est probablement   / sites/default/files/config_ [hashcode]/sync /. Ensuite, faites une importation de configuration   (en utilisant l'un de ces 3 outils ci-dessus).

0
ajouté

Je ne sais pas pourquoi les configurations sont identiques quand elles ne le devraient pas, mais je pense que le thème d'administration n'a pas les blocs "Onglets primaires" dans l'en-tête, vous pouvez vérifier votre disposition de production env Block et voir si Le bloc "tabs" est là (admin/structure/block/list/seven).

0
ajouté